Intermittent 404s
Resolved
Aug 18, 2026 at 5:47pm UTC
The issue has been identified, and access to all affected domains has been restored.
Analysis
A small set of environments had stale metadata after an extended period without a deployment. A routine maintenance operation inadvertantly made those environments inaccessible through their custom and preview domains.
Remediation
No data was lost. A gateway deployment restored access to the affected domains.
We have added validation and safeguards to prevent this failure from recurring. Out of an abundance of caution, we are also proactively monitoring the affected domains for any unusual behavior.
Affected services
Created
Aug 18, 2026 at 5:24pm UTC
Starting around 2026-08-18 17:24:09 UTC, a small set of environments unexpectedly started returning 404s.
Affected services