Some region-specific builds are failing
Resolved
Jun 29, 2026 at 10:08pm UTC
The issue seems to be resolved on the GitHub side, and AU and EU builds are consistently and successfully deploying. We will continue to monitor.
Affected services
Updated
Jun 29, 2026 at 4:33pm UTC
The root cause is GitHub rate limiting Packagist, which has backed up their queue.
https://github.com/composer/packagist/issues/1612#issuecomment-4833898072
We are seeing improvements in the AU and EU and are continuing to monitor.
Affected services
Created
Jun 29, 2026 at 5:08am UTC
We’re investigating an issue where Craft Cloud builds are failing for some projects in some regions (primarily Australia and a few in Germany).
- It doesn’t appear to be related to GitHub/source control rate-limiting.
- The same code that has an issue in AU works fine in a different region.
- For some projects, adding a client GitHub personal access token seems to help, in that it happens less frequently, but it still occasionally happens.
- It only affects a handful of projects in the AU and EU regions.
- It might be related to Composer/Packagist (https://github.com/composer/packagist/issues/1612), which very much describes the issue, and we are following up there as well.
We’ll post more information as we have it.
Affected services