Back to overview
Degraded

Cached requests are empty or incomplete

May 15 at 09:29am PDT
Affected services
DNS & Gateway

Resolved
May 15 at 10:33am PDT

We have identified the cause and have deployed a fix that resolve this issue and prevent it from happening in the future.

Diagnosis

In the event of an unstable network connection between Cloudflare's servers and Craft Cloud's origin servers, combined with a threshold of traffic – there was the possibility that responses could be cached in an incomplete (or empty) state.

The unstable connection is not a issue in itself – network fluctuations are inevitable and need to be accounted for.

Resolution

We deployed several safeguards to our gateway to remedy this and prevent this behavior from happening in the future.

We have also added specific monitoring and alerts around the symptoms for a more proactive response.

Issues should be immediately resolved and no action is required by customers.

Created
May 15 at 09:29am PDT

Some customers are experiencing empty or partial responses for cached requests.