Craft Cloud is experiencing issues
Resolved
Jun 12 at 06:19pm PDT
Cloudflare has posted a post-mortem of the incident here: https://blog.cloudflare.com/cloudflare-service-outage-june-12-2025/
Affected services
3rd-Party Services
CDN
DNS & Gateway
Updated
Jun 12 at 01:41pm PDT
All Craft Cloud sites appear to be up and running again.
We will continue to monitor for any interruptions in service.
Affected services
3rd-Party Services
CDN
DNS & Gateway
Updated
Jun 12 at 01:11pm PDT
We're seeing Craft Cloud sites start to recover very quickly now. We are continuing to monitor the recovery.
Affected services
3rd-Party Services
CDN
DNS & Gateway
Updated
Jun 12 at 01:04pm PDT
Latest update from Cloudflare:
"Cloudflare’s critical Workers KV service went offline due to an outage of a 3rd party service that is a key dependency. As a result, certain Cloudflare products that rely on KV service to store and disseminate information are unavailable.
...
We are aware of the deep impact this outage has caused and are working with all hands on deck to restore all services as quickly as possible."
Affected services
3rd-Party Services
CDN
DNS & Gateway
Updated
Jun 12 at 12:28pm PDT
Cloudflare is reporting that some services are slowly starting to recover.
We are monitoring Craft Cloud site and infrastructure as this happens.
Affected services
3rd-Party Services
CDN
DNS & Gateway
Updated
Jun 12 at 11:56am PDT
Cloudflare is still investigating the issue.
Affected services
3rd-Party Services
CDN
DNS & Gateway
Updated
Jun 12 at 11:32am PDT
Cloudflare has updated its status page now.
"Broad Cloudflare service outages"
Affected services
3rd-Party Services
CDN
DNS & Gateway
Updated
Jun 12 at 11:30am PDT
We have confirmed that this is a major Cloudflare outage affecting large swaths of the internet. We’ll update here when we have more information.
Affected services
3rd-Party Services
CDN
DNS & Gateway
Updated
Jun 12 at 11:19am PDT
Cloudflare does appear to be having a major outage. https://downdetector.com/status/cloudflare/
Affected services
3rd-Party Services
CDN
DNS & Gateway
Created
Jun 12 at 11:14am PDT
We're investigating and will update soon, but it appears that Cloudflare is having an outage.
Affected services
3rd-Party Services
CDN
DNS & Gateway