Back to overview
Degraded

Deployments are broken for some projects

Jun 13 at 08:30am PDT
Affected services
Deployments

Resolved
Jun 13 at 11:21am PDT

v1.62.0 of the Cloud API introduced a regression where specific node and craft-cloud.yaml configurations would not get their artifacts published to the CDN during a build.

This is resolved in v1.62.3, which has been deployed to all regions.

In order to mitigate issues like this going forward, we are expanding our integration test coverage to cover scenarios like this.

Updated
Jun 13 at 10:15am PDT

The cause has been identified, and a fix has been deployed. We are monitoring the affected sites and will post a post-mortem shortly.

Created
Jun 13 at 08:30am PDT

We are investigating and will follow up here when we know more.