Unexpected 504s in the European region
Resolved
Jul 16 at 03:42pm PDT
Around 6:15 AM PT, we started to receive reports of performance issues and timeouts for some sites in the EU region.
The issue was resolved around 6:30 AM PT.
The underlying issue was a flood of DDOS traffic that made it through our firewall and affected some infrastructure in that region.
We have increased the resources available in that region to help mitigate situations like this in the future.
We have adjusted our global firewall rules to help further mitigate future issues like this.
Over the next few weeks, we will roll out more robust rate limiting and throttling rules for any DDOS-like traffic, considering the detection of bots and legitimate traffic spikes.
In the long term, we are investigating ways to isolate infrastructure resources further to minimize potential collateral damage that may cause outages.
We encourage all Craft Cloud customers to take advantage of its native static caching abilities as much as possible. This will not only dramatically increase your site’s performance but also make your projects more resilient to future outages.
Affected services
DNS & Gateway
Updated
Jul 16 at 06:35am PDT
Requests are now resolving as expected.
The issue appears to be caused by a third-party outage localized in the European (possibly just the U.K.) region.
Further investigation and a full report will follow.
Affected services
DNS & Gateway
Created
Jul 16 at 06:19am PDT
We've had multiple reports of sporadic 504 responses across the European region. We are actively investigating.
Affected services
DNS & Gateway